Nazwy zdefiniowane – czytelne formuły

Witam,
Przy tworzeniu formuł z reguły posługujemy się odwołaniami do zakresu (najczęściej w formie A1, czy A1:B1). Takie postępowanie jest jak najbardziej prawidłowe i czytelne dla Excela, pozostaje jednak pytanie „Czy jest czytelne dla nas?”.

O wiele łatwiej jest pracować z formułą

suma(sprzedaż styczeń)
niż
suma(B3)

podobnie w poniższym przypadku

 =brutto * procent_vat
 =C2*D2.


Słowa takie jak sprzedaż, styczeń czy brutto w powyższych przykładach to właśnie nazwy zdefiniowane, pod którymi ukrywają się pojedyncze komórki, ich zakresy lub formuły.

W poniższych przykładach posługiwać się będziemy grupą narzędzi Nazwy zdefiniowane na karcie Formuły.



Grupa Nazwy zdefiniowane na karcie Formuły

W ćwiczeniach będę posługiwał się tym plikiem.

Nadawanie nazw zakresom
Zaczniemy od najprostszej metody tworzenia nazwy zdefiniowanej. Zaznaczę w zwykły sposób zakres od komówki B2 do M2. W polu adresu wpiszę Sprzedaż_Janek (u mnie jest to sprzedaż Janka).




Tabelka z danymi sprzedaży

W tym momencie możemy użyć funkcji =suma(sprzedaż_Janek) zamiast =suma(B2:M2). Warto zwrócić uwagę że już wpisując tą funkcje, Excel podpowiada nam nazwę sprzedaż_Janek, tak jak nazwy zwykłych funkcji.

Nadawanie nazw stałym
Nazwy nie muszą dotyczyć zakresów, można w niej umieścić jakąś stałą wartość. W grupie przycisków pokazanej wyżej klikamy Menedżer nazw. Kliknijmy przycisk Nowy. W nazwie wpiszmy procent_premii, a w polu odwołuje się do =0,002.

Teraz możemy wpisać formułę obliczającą premię dla Janka.

=SUMA(sprzedaż_Janek)*Procent_premii

Kilka uwag na temat nazw
Tworząc nazwy należy pamiętać o kilku rzeczach:

  1. Jedna nazwa może występować tylko raz, nie można przypisać do dwóch zakresów takich samych nazw.
  2. Nazwy nie mogą zawierać odstępów, można za to użyć znaku podkreślenia, tak jak w powyższych przykładach. Nie mogą też zawierać symboli poza kropką i podkreśleniem.
  3. Nazwa nie może się zaczynać od cyfr, ani wyglądać jak adres komórki.

Nadawanie nazw formułom
Nadaliśmy już nazwę zakresowi komórek, oraz konkretnej stałej wartości. Tym razem chcemy mieć pod nazwą ukrytą nie stałą wartość, ale wynik obliczenia. Formuła tego obliczenia nie powinna być w żadnej komórce, aby nie zmniejszać czytelności arkusza.

Dodajmy więc ponownie nową nazwę i wypełnijmy pola jak poniżej.

W tej chwili wszędzie w pliku, gdzie będziemy potrzebowali sumarycznej sprzedaży Janka, wystarczy użyć tej nazwy w formule.

Usuwanie nazw

Wejdźmy jeszcze raz do Menedżera nazw.

Wystarczy wybrać nazwę i kliknąć Usuń. Usunę więc obie nazwy. Po zamknięciu okna wcześniej wpisane funkcje przestają działać, ponieważ Excel nie rozpoznaje już ciągów znaków „Procent_premi” i „Sprzedaż_Janek”.

W kolejnym poście napiszę jak nazwy można nadawać automatycznie dla całej tabeli, i jak je sprawnie wykorzystywać.

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *