Formatowanie warunkowe wykresów

Witam,
Excel 2007 posiada rozbudowane możliwości formatowania warunkowego wartości w komórkach, nie umożliwia jednak takiego formatowania na wykresach. Każdą serię danych można wyświetlić w innym kolorze, jednak nie są one zależne od wartości danych. Pokażę dzisiaj jak stworzyć wykres kolumnowy, w którym kolumny mają kolor odpowiadający wartościom.

Wykres z kolumnami, których kolor zależy od wartości sprzedaży.

  W przykładzie posłużę się tym plikiem. Znajduje się w nim historia sprzedaży w ciągu dwunastu miesięcy.

Podstawowe dane dotyczące sprzedaży

Dane są z grubsza z zakresu od -200 do 1000. Jeżeli stworzę z tych danych wykres kolumnowy, wszystkie kolumny będą miały ten sam kolor, ponieważ będą należeć do jednej serii danych. Utworzę cztery dodatkowe serie danych:

  • Wartości mniejsze niż 0,
  • pomiędzy 0 a 333
  • pomiędzy 333 a 666,
  • oraz większe niż 666.
  Nadam nagłówkom odpowiednie nazwy, moja tabela wygląda teraz tak:
 Uzupełnię kolumny o odpowiednie formuły. Do danej kolumny dane będą przepisywane, jeżeli wartości z kolumny sprzedaż będzie odpowiadać odpowiedniemu zakresowi, np.:
  • Do kolumny 0 przekopiuje się wartość tylko z wiersza styczeń, bo tylko ta wartość jest mniejsza od zera.
  • Do drugiej kolumny przypisane zostaną wartości miesięcy maj, czerwiec, wrzesień i listopad.
  Do komórki C3 wpisuję formułę: =JEŻELI($B3<=C$2;$B3;0) i przeciągam ją na całą wysokość.
Do komórki D3 wpisuję formułę =JEŻELI(ORAZ($B3<=D$2;$B3>C$2);$B3;0) i przeciągam ją na cały zakres D3:F14.
  Powstała teraz tabela, w której dane z kolumny sprzedaż są przekopiowane do odpowiednich zakresów.
Zakresy uzupełnione o dane przy pomocy formuł
 Z tak utworzonych danych tworzę wykres kolumnowy obejmujący zakres A2:F14.
Klikam prawym klawiszem na nowy wykres i wybieram Zaznacz dane…
 W powyższym oknie zaznaczam serię sprzedaż i klikam usuń. Mój wykres wygląda teraz tak:
 
Wykres przed zmianami wyglądu
 
  Pozostaje jeszcze tylko kosmetyka. Klikam prawym klawiszem na dowolny słupek i wybieram Formatuj serię danych… W nowym oknie zmieniam opcję Nakładanie serii na 100%. W tym momencie kolory ustawione są dość losowo, żeby zmienić kolor danej serii należy w oknie Formatowanie serii danych…, w grupie Wypełnienie ustawić Wypełnienie pełne  i poniżej wskazać odpowiedni kolor. Należy wykonać to dla  każdej serii, czyli każdego z zakresów wartości.
Ustawienia wypełnienia przy formatowaniu serii
  Warto jeszcze po zaznaczeniu wykresu otworzyć kartę Układ i usunąć legendę oraz dodać tytuł wykresu.

Ostateczny wykres, najwyższa sprzedaż jest wyróżniona na zielono.

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *