[Pytanie czytelnika] Uzupełnianie combobox lub listbox za pomocą stałej tablicowej

Jeden z użytkowników zadał pytanie:

Standardowo ComboBox czy ListBox mogą pobierać wartości z zakresu komórek arkusza. Czy jest jakiś sposób (trik) by te kontrolki (formanty) mogły być zasilane ze stałej tablicowej?

Pomoc do programu jest w tym przypadku jasna. Pole Input range musi być zakresem. Nie można więc wstawić tam formuły. Załóżmy, że ustawiamy pole combo  ten sposób:

W polu A8 nie znajdziemy żadnej wartości z zakresu A1:A5, jedynie indeks wybranej pozycji (1,2,3 itd.). Zakres wejściowy będzie więc potrzebny jeszcze raz, jeżeli chcemy gdzieś wstawić konkretną wybraną wartość (tutaj marzec). =INDEKS(A1:A5,A8)

Pytanie użytkownika – funkcja UDF

Jeden z czytelników zadał mi niedawno pytanie:

W Excelu utworzyłem moduł MODULE1 w nim Funkcja
w której tylko jedna instrukcja

Range(„A1″).value = 15
Pojawia się bład ” #ARG! ”
skad to ?
Jest to EXCEL 2007.

Funkcje UDF (User Defined Function, Funkcje zdefiniowane przez użytkownika) rozszerzają możliwości naszych formuł. Tak jak standardowe funkcje, przyjmują one jakieś argumenty (lub nie) i zawsze zwracają dokładnie jedną wartość.

Funckję UDF pisze się tak jak standardowe funkcje VBA. Muszą jednak spełniać szereg warunków, aby działały prawidłowo w formułach.

Czytaj więcej...